Ok guys, thought I would share my experience as I was having major difficulty getting the qt wallet to run. When running it would throw up a "libminiunpnp" error or something to that effect.

Any way, tried googling the error and really got nowhere so decided to have a go at compiling myself.

crowitec helped me obtain the source files from git and I followed his instructions, however when coming to "make" the file, errors yet again!!

This time different, compiler complaining about big_num, lots of times.

crowitec was unfortunately busy so I had to "go it alone" to try and sort this out (I don't give up easily).

LOTS of googling later, I had some idea that it was possibly a libssl conflict and newer versions don't seem to like compiling the qt.

So I decided to make it slightly easier on myself and did the following -

wget http://download.qt.io/official_releases/qt/5.7/5.7.0/qt-opensource-linux-x64-5.7.0.run

chmod +x qt-opensource-linux-x64-5.7.0.run

./qt-opensource-linux-x64-5.7.0.run

Ok, Qt Creator installed (you can use Ubuntu's own installer I believe rather than CLI)

Open the file "polytimos.pro" from the github using Qt Creator. Then went to "Build-->Run Qmake"

This then produced a new Makefile

Tried to "make" and again throwing up errors. (Same as before, big_num rubbish)

Ok, so to solve this you need to do the following -

sudo nano /etc/apt/sources.list

Added the two following lines to the sources list -

deb http://httpredir.debian.org/debian/ jessie-backports main contrib non-free
deb-src http://httpredir.debian.org/debian/ jessie-backports main contrib non-free

sudo apt-get update

sudo apt-get remove libssl-dev

sudo apt-get install -t jessie-backports libssl-dev

Ran make again, and everything worked perfectly.

If you are having trouble with the qt, hopefully this will help you if you fancy self-compiling

There is a possibility after exiting and restarting the wallet, for example when rebooting, you get an error about this -

error while loading shared libraries: libdb_cxx-5.3.so:

If you do, please do - sudo apt-get install libdb++-dev

Cheers

OvEr